The "atom:uri" element should be renamed or changed.
The "atom:uri" element says nothing about its semantics or meaning, just about the datatype of its content. As Danny Ayers writes: "Using atom:uri/atom:iri is only marginally better than saying atom:string - it describes how the identifier is put together, it tells you nothing about what's being identified.". It is also in conflict with the term "IRI" which is the one used in the rest of the specification.
Rename the "atom:uri" element or change its type to a Link Construct and add some text to explain what information this element is actually holding. More semantics is needed.
Atom parsers which expects "atom:uri" in the documents, although they are based on a non-standard nor final version of the Atom document format.
As this change is mostly editorial and not technical, I think the authors are free to find the best suited name for the element.